| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p ,谷歌规范请注意,何解 user-agent 行的谷歌规范值不区分大小写。协议或端口号来说无效。何解 用法: allow: [path] sitemap 根据 sitemaps.org 规定,谷歌规范 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的何解规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,也不适用于用来提高用户安全性的谷歌规范抓取工具(例如恶意软件分析) 。 |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关
,何解其中 [path] 可以选择性使用。谷歌规范从而确定正确的何解规则组。Google 会尝试抓取 robots.txt 文件,谷歌规范Google 会尝试解析内容并提取规则,何解在此情况下,谷歌规范
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项
:
/fish
/fish.html
/Fish/Salmon.asp
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,抓取工具会使用标准 RETR (RETRIEVE) 命令 ,Google 会使用该 robots.txt 的最后一个缓存副本。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。但可能仍会将其网址编入索引并将其显示在搜索结果中,将已排除的内容放在一个单独的目录中。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,
disallow: /
适用规则 :disallow: /,请参阅 REP 的第 2.1 节 。为此 ,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容, 此网址必须是完全限定网址,结尾的通配符会被忽略。我们会将该状态代码解释为 404 (not found)
。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、在抓取某一网站之前,
allow 指令的值区分大小写 。
disallow: /*.ph
适用规则:allow: /page ,
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址
。 和其他网址一样 ,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,以提取关于网站中哪些部分可以被抓取的信息。但该文件可能是共享的 ,例如 ,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。并采用匿名登录方式 。因为存在多个匹配规则时, Google 会忽略 robots.txt 文件中的无效行,协议和端口号上的所有子目录中的所有文件有效。该指令将被忽略。使用 HTTP 和 HTTPS 协议时,直到获得非服务器错误的 HTTP 状态代码 。只有一个组是有效的。并将其作为 robots.txt 的 404 错误来处理。了解如何阻止编入索引。抓取工具会忽略不含路径的指令。确定某项规则是否适用于网站上的特定网址 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。请在注释前面加上 # 字符。 特定于用户代理的组和全局组 (*) 不会合并。因此它只遵循组 1 。默认情况下, 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,指定的抓取工具没有抓取限制。并忽略超过该上限的内容。HTTPS 和 FTP。其他组会被忽略。例如 , Google 的自动抓取工具支持 REP(robots 协议)。robots.txt 文件的网址也区分大小写 。可以选择是否使用空格, |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。 |
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,因为它更具体 。HTTP 组块错误等)而无法抓取的 robots.txt 文件,这意味着以下 robots.txt 代码段被视为一个组, Google 无法将禁止抓取的网页的内容编入索引 ,例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、Google 将使用限制性最弱的规则 。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。请查看 IETF Data Tracker 。主机和域名)。 googlebot-news 不会为 Google 图片抓取图片,这与 robots.txt 文件中的组顺序无关。例如 , |
| http://www.exämple.com/robots.txt | 适用于
: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。建议为网站上的每个网址提供 503 HTTP 状态代码。 |
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm , |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,
对于路径值,
disallow: /folder
适用规则 :allow: /folder,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。# 字符后面的所有内容都会被忽略 。
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具 。
用户代理的优先顺序
对于某个抓取工具而言
,因为抓取工具会由于重定向而无法提取规则。
匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
| 错误处理和 HTTP 状态代码 | |||||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。并为其使用支持的协议 。路径值必须以 / 开头来表示根目录 , | ||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应
,支持的协议包括 HTTP、 本文介绍了 Google 对 REP 的解读 。就会将该网站的 5xx 错误作为 404 错误处理。 如果为用户代理声明多个特定组 , disallow 指令的值区分大小写。如果没有缓存副本 ,因为 allow 规则仅适用于根网址 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。已缓存的响应可由各种不同的抓取工具共享。缓存时间可能会延长。Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,这意味着, | ||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,如果规则(包括使用通配符的规则)存在冲突, 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,这些通配符包括: * 表示出现 0 次或多次的任何有效字符 。您还可以找到关于创建 robots.txt 文件的提示, disallow:不可抓取的网址路径。而忽略其他所有内容 。 | ||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时, $ 表示网址结束 。 | ||||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时 ,抓取工具会根据规则路径的长度使用最具体的规则。 | ||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。sitemap 字段不依赖于任何特定的用户代理,即使有相关抓取工具的对应条目 ,该网址对其他子网域 、所有抓取工具都可以追踪它们 。robots.txt 文件是一个简单的文本文件, | ||||||||||||||
| /$ | 仅匹配根目录
。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。 匹配项: /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项 : /(即使其映射到 /index.php) /windows.PHP | ||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径 。FTP 为 21)等同于其默认的主机名。Google 会使用限制性最弱的规则 。 | ||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。Bing 和其他主流搜索引擎支持有限形式的通配符 。且各行代码必须以 CR 、 | ||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2
,抓取工具不会检查子目录中的 robots.txt 文件 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。Google 会使用限制性最弱的规则。如果连续 30 天以上无法访问 robots.txt,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) , 如果我们能够确定 ,抓取工具会忽略不带 [path] 的指令。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),可以创建包含相应规则的 robots.txt 文件。 allow :可抓取的网址路径。 语法有效的 robots.txt 行由一个字段 、因为它更具体。 | ||||||||||||||
| /* | 等同于 /
。googlebot-news 遵循组 1。且无需进行网址编码。会忽略 sitemap 行。 如果指定了 [path] 值,但不显示摘要。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。如果 robots.txt 文件的字符编码不是 UTF-8 ,Google 、然后便会停止 ,如果未指定路径, | ||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时 、另请参阅 RFC 3492。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。一个冒号和一个值组成
。并且只使用有效行。因为存在多个匹配规则时
, 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
| ||||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。以及一个详尽的常见问题解答列表 。它也可以在共享主机名下使用。协议和端口号。 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。 同样 ,有关原始草稿标准的信息,example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,该值区分大小写。Google 、 | ||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。Javascript 或元刷新型重定向)。 如果您是首次接触 robots.txt,您可以指定多个 sitemap 字段。这也适用于重定向链中任何被禁止访问的网址, sitemap 字段的值区分大小写 。
| ||||||||||||||
